Can't compile simple-webserver example

I am getting the following errors when I attempt to compile my simple-webserver.ino

*** [.pio\build\esp32doit-devkit-v1\src\simple-webserverV2.ino.cpp.o] Error 1
*** [.pio\build\esp32doit-devkit-v1\libb40\ESP Async WebServer\AsyncEventSource.cpp.o] Error 1
*** [.pio\build\esp32doit-devkit-v1\libb40\ESP Async WebServer\SPIFFSEditor.cpp.o] Error 1
*** [.pio\build\esp32doit-devkit-v1\libb40\ESP Async WebServer\AsyncWebSocket.cpp.o] Error 1

My platformio.ini file looks like:
[env]

platform = espressif32

#platform = https://github.com/platformio/platform-espressif32.git#feature/arduino-upstream

framework = arduino

platform_packages =

framework-arduinoespressif32 @ https://github.com/husarnet/arduino-esp32/releases/download/1.0.4-1/arduino-husarnet-esp32.zip

lib_deps =
Husarnet ESP32

[env:esp32doit-devkit-v1]
board = esp32doit-devkit-v1
framework = arduino

I have:
Run pio update
Deleted (so they could rebuild from scratch):
.platformio/.cache
.platformio/packages
.platformio/platforms

Any help would be appreciated.

Hi @hickse,

You probably tried to run this example: https://github.com/husarnet/husarnet-esp32/tree/master/examples/simple-webserver ?

I have just tested this project and everything works good.

If you are looking for more examples with Husarnet and a simple webserver, this one may be interesting for you: https://github.com/husarnet/esp32-internet-ota

Please let me know if you will face any issues running it.

Best,
Dominik

Thanks for responding Dominik, Glad to see this effort is still active.
I ran the esp32-internet-ota sample and came up with the same 3 lines of errors mentioned above. It looks like there is a systemic problem with my Platformio setup. I’ll take it up with that group.