Failed to enable unit: unit file husarnet.service does not exist

I am unable to start the husarnet post installation on my Ubuntu 18.04.
I am running the following command, following the installation instructions:

curl -s | sudo bash

At the end I get the following message:
Screenshot 2023-05-19 140619
As you can also see, I tried manually starting the daemon without success. If I run sudo husarnet status it says that the daemon is not running.

I also re-flashed the whole OS and tried it on the fresh 18.04 on my Jetson with the same results.

Additionally, I tried installing Husarnet by manually setting up the repos and total manual installation, all without results.

If I run sudo systemctl enable husarnet, I get the following error message: “Failed to enable unit: Unit file husarnet.service does not exist.”

Any idea what might be causing it?

Thank you.

I meet the same problem. Did you have some solutions?

Hello @mrcube3, @sunyuan789

Thanks for the report. I’ll try to reproduce this, right now I can’t.

You can try executing:

sudo husarnet daemon service-install

To install systemctl service manually.

Please provide the output of the command if it fails.


Hi Szymek,

Thank you for the quick response! It seems that it has partially fixed the issue, the daemon now runs but now I am stuck on joining:
I had a look at the trouble shooting guide ( Understanding Husarnet Status and Troubleshooting | Husarnet) but it does not help.

Hello mrcube3,

To troubleshoot, I will need the logs from journalctl -u husarnet and husarnet status output
You can share them here or alternatively you can send them to


Hi ympek, Szymek,

Thank you for your help. I reflashed the OS and on the new install it works fine with Szymek’s suggestion. I am able to join fine.
Not sure what happened with the old OS as it is identical to this new one :man_shrugging:

Have a nice day!

1 Like