IPV6 Problems using ROS melodic

Hello together,

we are trying to use Husarnet with ROS 1 Melodic, following the setup guide. But when using ‘export ROS_IPV6=on’ and then running roscore, we get the error ‘[ERROR] [1641845350.101209283]: [registerService] Failed to contact master at [server:11311]. Retrying…’

Any ideas?

Full steps to reproduction:

docker pull osrf/ros:melodic-desktop-full
docker run -it --rm --net=host osrf/ros:melodic-desktop-full /bin/bash
export ROS_IPV6=on

Full output:

... logging to /root/.ros/log/2bae647e-7251-11ec-85b6-b42e99464746/roslaunch-server-35.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://server:46123/
ros_comm version 1.14.11


 * /rosdistro: melodic
 * /rosversion: 1.14.11


auto-starting new master
process[master]: started with pid [45]

setting /run_id to 2bae647e-7251-11ec-85b6-b42e99464746
process[rosout-1]: started with pid [56]
started core service [/rosout]
[ERROR] [1641845350.101209283]: [registerService] Failed to contact master at [server:11311].  Retrying...

Found the solution: You also need to set ROS_HOSTNAME to the correct one with export ROS_HOSTNAME=$HOSTNAME


Raph, when it comes to using ROS 1 with Husarnet in Docker, I have prepared recently this demo project: https://github.com/DominikN/rosbridge_websocket_demo . Everything 100% in Docker.

Of course you can use Husarnet running in your host as well as in your example.

I’m glad that you found the answer :slight_smile: