Issue with connection to Husarnet

I watched a few tutorials on how to use Husarnet and it was exactly what I needed for my project. So I tried it the past few days, but I’m having real trouble with the connection. Because I cannot find my boards (ESP32) in the Husarnet app.

I used Arduino IDE and kept on getting this error message:

e[0;32mI (280) heap_init: Initializing. RAM available for dynamic allocation:e[0m
e[0;32mI (280) heap_init: At 3FFAE6E0 len 00011920 (70 KiB): DRAMe[0m
e[0;32mI (282) heap_init: At 3FFC9490 len 00016B70 (90 KiB): DRAMe[0m
e[0;32mI (288) heap_init: At 3FFE0440 len 00003BC0 (14 KiB): D/IRAMe[0m
e[0;32mI (295) heap_init: At 3FFE4350 len 0001BCB0 (111 KiB): D/IRAMe[0m
e[0;32mI (301) heap_init: At 400919CC len 0000E634 (57 KiB): IRAMe[0m
assertion "false && "item should have been present in cache"" failed: file "/build/esp-idf/components/nvs_flash/src/nvs_item_hash_list.cpp", line 85, function: void nvs::HashList::erase(size_t)
abort() was called at PC 0x400de0c7 on core 0

Backtrace: 0x40087f8c:0x3ffb1fe0 0x4008808b:0x3ffb2000 0x400de0c7:0x3ffb2020 0x400e3a60:0x3ffb2050 0x400e2f5a:0x3ffb2070 0x400e3235:0x3ffb20b0 0x400e2594:0x3ffb2100 0x400e218e:0x3ffb2150 0x400e2217:0x3ffb2170 0x400e2242:0x3ffb2190 0x400d2c90:0x3ffb21b0 0x4011c96f:0x3ffb21d0 0x400e02ee:0x3ffb2200

ets Jun  8 2016 00:22:57

rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
mode:DIO, clock div:1
entry 0x40078a58

I was wondering if anyone has ever had the same problem. I’m an absolute beginner, so I’m desperately looking for help.
Thank you in advance.

Hi Sven,

could you share a code that you uploaded to ESP32 that produced that error message?

Please also upload a photo presenting which version of ESP32 dev board are you using.

And take a look and compare your project settings with those from my screenshot that work fine in my project:


Hi dominik,
Thank you very much for your reply!
Those settings worked!
Thank you very much, this helps me a lot.