Joining Network

I see this has been asked before, but I’m stuck with this as well, wherein when I run:
sudo husarnet join $JOINCODE <hostname>, using my joincode and hostname, I get:

[1147878] joining…
[1149879] joining…
[1151881] joining…
[1153883] joining…
[1155885] joining…
[1157887] joining…
[1159889] joining…
[1161890] Request timed out.
Common reasons:

  1. This device is already added by Join Code to another network (maybe by another user)
  2. You have exceeded maximum number of devices for your plan - upgrade your account at
  3. If you use self-hosted Husarnet infrastructure make sure your Husarnet Client is configured to use it (eg. sudo husarnet setup-server
    If the problem persists, find more information here:

However, on my web dashboard, my device has been added, but the status is ‘Offline’. What could be reasons for this, and how do I fix it?

When I try to connect through the websetup by running sudo husarnet websetup and Add Husarnet Device to your account I get an error message saying: Could not connect to your device. Make sure it is running.

UPDATE 2: It works fine, if I run sudo ufw disable , which turns off the firewall, so I guess the issues was with that. Is there any way to allow Husarnet without turning ufw off completely?

Hello @greyhame

Husarnet plugs itself into ip6tables during installation and introduces following rules:

INPUT -s fc94::/16 -i lo -j ACCEPT
INPUT -s fc94::/16 \! -i hnet0 -j DROP

Since you are using ufw, these will be of no effect, because ufw will override them. If using different firewall with Husarnet, you need to specify similar rules in configuration yourself.

Assuming you have outgoing traffic on “allow” (this is the default with ufw), you need also to allow incoming traffic on hnet0 (Husarnet) interface.

Enable ufw if not yet enabled and try this rule:

ufw allow in on hnet0 from fc94::/16

Then check if device is online in the dashboard.

Best regards