Joining to Husarnet network

Hi All,

I’ve being trying to join to a Husarnet network following the process indicated on the documentation.

husarnet join fc94:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:932a/xxxxxxxxxxxxxxxxxxxxxx mydevhostname

But it fails when I run the previous command showing the following output:

2021-10-04T11:28:21.193457720Z [6401566240] joining...
2021-10-04T11:28:23.194871262Z [6401568242] joining...
2021-10-04T11:28:25.196368493Z [6401570243] joining...
2021-10-04T11:28:27.198188169Z [6401572245] joining...
2021-10-04T11:28:29.199853581Z [6401574247] joining...
2021-10-04T11:28:31.201059960Z [6401576248] joining...
2021-10-04T11:28:33.202210844Z [6401578249] joining...
2021-10-04T11:28:35.203433561Z [6401580250] Request timed out.
2021-10-04T11:28:35.203459820Z Common reasons:
2021-10-04T11:28:35.203462676Z 1) This device is already added by Join Code to another network (maybe by another user)
2021-10-04T11:28:35.203465348Z 2) You have exceeded maximum number of devices for your plan - upgrade your account at https://app.husarnet.com/billing/account/
2021-10-04T11:28:35.203469868Z 3) If you use self-hosted Husarnet infrastructure make sure your Husarnet Client is configured to use it (eg. sudo husarnet setup-server app.husarnet.mydomain.com)
2021-10-04T11:28:35.203472424Z If the problem persists, find more information here: https://husarnet.com/docs/tutorial-troubleshooting/

But my device is not joined to other network, I’m not using a self-hosted Husarnet infrastructure and I have not execeed the maximum number of devices in my plan cause there are no devices yet.
I tries a few things but non of them worked so far:

  1. Restart Husarnet service
  2. Disable and enable the service
  3. Kill all the processes related to husarnet and start the service again
  4. Uninstall and install again

Has anyone faced the same issue? I would really appreciate some help.
Thank you in advance!

1 Like

Hi Lidia,

We have already solved your issue.

For rest of you: It’s related to Let’s Encrypt certificate authority root cert update.

In a separate post I wrote how to solve potential issues related to that:
https://community.husarnet.com/t/let-s-encrypt-root-cert-update-issue

Best,
Dominik


Husarnet team