ROS2 chatter topic not found

I’ve followed the follwing link steps

and was able to actually ping another laptop from mine using pin6
however when I publish from one device using the mentioned command

ros2 run demo_nodes_cpp talker`

and trying ros2 topic list from the other laptop, the chatter topic is not present

this is a screenshot of the status from the web dashboard

and this is the output of hasurnet status

Version: 2021.11.26.1
Husarnet IP address: fc94:0397:df69:92f5:edad:f4a4:9bf6:f567
Known hostnames: master unity
UDP connection to base: []:5582
Peer fc94:b98f:8430:4a93:5248:dc0b:9e77:75c8
  Known hostnames: ros
  addresses from base=[]:5582 []:5582 []:5582 []:5582 
  secure connection established
Peer fc94:b01d:1803:8dd8:b293:5c7d:7639:932a
  addresses from base=[]:5582 []:30650 []:5582 []:5582 
  secure connection established

Am I missing something ?

Hi @SeifMostafa , please share your DDS config file and the compose file you are using.

Instead of a simple DDS Discovery Protocol, you can also try using a Fast DDS Discovery Server. Here’s the open source demo - GitHub - DominikN/discovery-server-superclient-demo: A working demo with a Fast DDS Discovery Server and a Super Client DDS Config.


Thanks for the reply, this is my DDS configuration file

<CycloneDDS xmlns="" xmlns:xsi="" xsi:schemaLocation="">
<Domain id="any">
<Peer address="[ros]"/>
<!--  example: <Peer address="[fc94:dd2c:a2e6:d645:1a36:****:****:****]"/>  -->

for the peer address, I also tried putting the actual address shown on the web interface for the client ROS

as for the link you attached, I don’t quite understand how to apply that in my case.
however, I noticed that there are 2 configurations one for the server and another for the client, to my understanding Hausrnet already implements the Server side.

Hello @SeifMostafa

Please try removing square brackets in the address attribute.

i.e not

<Peer address="[fc94:dd2c:a2e6:d645:1a36:****:****:****]"/>

But instead

<Peer address="fc94:dd2c:a2e6:d645:1a36:****:****:****"/>

Let us know if that helps.


I have the same issue, removing the bracket did not help. I run the talker on a server and husarnet status shows my laptop with green dots for active/securce/peer to peer, but if I run the talker on the server, I don’t get the topic on the laptop