[Solved] Master host not being set (Detected on 28th of October 2022)

Hi @dominik , and @ympek.

On Friday we detected that rostopic list was not working for ROS 1 (Noetic) when we had ROS_MASTER_URI=http://master:11311.

Turns out that in Husarnet App (https://app.husarnet.com/) I see the “robot” set to master:

But if I check /etc/hosts on both 1_xterm and ruben-alves-dell, the master is pointing to 0000:0000:0000:0000:0000:0000:0000:0001 on both devices.

In Husarnet App it also says that roscore is not running but it is really running.

I then tried setting the ruben-alves-dell device to master using the API and Husarnet API says {"status":"ok"}, yet the master is still 0000:0000:0000:0000:0000:0000:0000:0001 on /etc/hosts on both devices.

It is worth pointing out that this was detected on Friday (2022-10-28) but it is happening still today (2022-10-31), and it is negatively affecting us.

Could you please check why this happens and gives me some feedback?

I look forward to hearing from you.

Hello @ralves

Thank you for the report.
As tomorrow is holiday in Poland, we will look into the problem on Wednesday and will come back to you.

Szymek from Husarnet team

1 Like

Thanks @ympek,

I look forward to hearing from you.

Hi @ralves,

We have reproduced your issues on our end and have fixed it. Please test how your system works after our fixes and let us know.


Husarnet team

1 Like

Hi @dominik,

I’ve been testing it, and it seems to be working nicely.

Thank you very much for having it solved.



Hi @ralves ,

thanks for the feedback! I’m glad to hear that it works fine now.