Unable to Join - ERROR: timeout

Hi Guys,

I just stumbled upon your project and wanted to give it a test.
I’ve tried to install it on two debian machines and both won’t join the network.

root@hb-house:~# sudo husarnet join xxx hb-house
 SUCCESS:  Successfully registered a join request
 SUCCESS:  Waiting for Base server connection (any protocol)…                                                                                                                                                                                                                                                                  
 SUCCESS:  Waiting for websetup connection…                                                                                                                                                                                                                                                                                    
 ERROR:  timeout 
root@hb-house:~# husarnet status
● CLI:                       2.0.180
● Daemon (running):          2.0.180
● Daemon (binary):           2.0.180

Feature flags
● Hooks:                     disabled
● Disabled hooks are not a reason to panic, unless your setup needs them
● Notifications:             enabled

Dashboard URL
● CLI:                       app.husarnet.com
● Daemon:                    app.husarnet.com

Connection status
● Base Server:      (UDP)

● Is ready to handle data?   yes
● Is ready to join?          yes
● Is joined?                 no

● Husarnet IP:

XXX (websetup)
● active     ● secure         ● tunelled

What could be the reason?

Hi @Z0RR0X :wave:

Which ISP are you using? Is that Fiber or 4G/5G? Are you behind CGNAT?

Can you send us results from following command to e-mail address support@husarnet.com?

sudo journalctl --unit husarnet --since yesterday

In your e-mail please mention this forum thread.

Regards, Filip

I faced the exact same issue today. Tried on different machines. Reinstalled and installed it again but no luck. The device appears in the web portal, but it doesn’t show the status as online.

ERROR: timeout finally appears after around 2 mins.

Yes, my local machine is on a 5G cellular connection. However, the second machine is with a data center in Germany (hetzner). Both do not connect. I’m not sure about the “CGNAT” question.

Were you able to resolve this? @Z0RR0X If yes, let me know what worked out well.

I have emailed the logs to support@husarnet.com

Hello @amit, @Z0RR0X

We have received the logs and we are working on your issues (so far, they seem to have different causes, so we will contact you separately via email)

Thank you for your patience
Szymon, Husarnet team

1 Like