Using Husarnet docker with ROS

Hi there,

I’m currently trying to use husarnet with Docker on my M1 mac since husarnet is not yet supported with MACOS. What I’m trying to accomplish is to be able to establish a P2P connection to a ros master running certain ROS nodes (such as camera nodes) so that I can access the camera from my M1 mac remotely.

I followed the tutorial from the husarnet doc for husarnet installation, and my robot using Linux installation. I was able to run the container from the terminal and able to join the network. However, how do I access the ROS topics from the ROS master? How do I run the Husarnet CLI such as the husarnet status etc. locally in my machine?

I am also planning to use husarnet with Foxglove studio for the ROS topics visualization, remotely. How can I achieve that?

Any help would be much appreciated, thank you.

we actually do have a beta version of Husarnet for MAC, which you can use.
In order to install Husarnet on MAC (reqired M1 architecture), simply run the following commands:

brew tap husarnet/tap-nightly
brew install husarnet
sudo husarnet daemon service-install

If You notice any bugs please let us know and we will correct them as soon as possible.

If You wish to continue using Husarnet inside Docker, let us know and we will help with that also.

Best regards,

Hi, thanks for the suggestions. I tried installing the beta version, but it seems like there are some issue with the installations, I’ve attached the screenshot to this. I tried joining a network but that failed too.

May I know how do I fix this? Thanks.

The errors you see are due to incompleteness of MacOS port, and will be fixed in next release(s).
That said, joining a group should work despite them displaying.

So, I kinda suspect it’s the firewall. Can you try disabling it (via System Preferences → Security & Privacy), and then try joining again? We are still working on proper firewall integration on MacOS.

If the service was installed properly, there should also be some logs present in /tmp/ (files named husarnet.log and/or husarnet.err.log). If you can find these please share them too.

ympek from Husarnet team